Group Group Group Group Group Group Group Group Group

Xcode RealmSwift: "No such module 'RealmSwift'

#1

Help. I cannot use the playground. Using Xcode 10.2. It keeps saying no such module in realmswift.

#2

Have you tried it with the Xcode version the book is compatible with?

#3

So, I have to download an older version of Xcode before I’m able to use this book?

#4
  1. Delete Realm folder
  2. Edit bootstrap.sh, modify REALM_VERSION to REALM_VERSION=“3.14.0”
  3. run ./bootstrap.sh
    You should be fine after above process!
#5

I’m having the same problem. I changed the REALM_VERSION=“3.14.2” but am still getting No such module ‘RealmSwift’

edit:
I fixed the problem. In the bootstrap.sh file the I found
-sdk iphonesimulator -destination “name=iPhone 8”

I didn’t have the iPhone 8 simulator installed. After installing the iPhone 8 simulator and naming it iPhone 8 fixed the problem.