As I mentioned before, I am enjoying the book. This comment is meant to be positive and constructive.
I am working on Checklists. I think the naming of variables could be improved. My errors have come from failure to capitalize certain words that are the same. I also have difficulty with with two lines that have indexPath and indexPaths in them. Then there is list vs lists and items vs item. Just because something is plural doesn’t mean it’s an array. It’s possible that its’ a naming convention I am unaware of.
I understand what’s happening, we implemented a parent on top of the to do item… called a checklist. I would suggest that it would be better called “category” or some other name that is further away from checklistItem. (Wouldn’t a checklist also have checklist items that are the individual items that make up the checklist?) I’m talking about the checklist items…
The file names could also be more distinctive. I had to take a couple of days off as my head was exploding with all the new info and upon first look I am not sure which is which. When I look inside it’s fairly clear, but it remains that the ChecklistViewController actually doesn’t manage checklists at all, its a list of checklistItems. I know they will be grouped, but shouldn’t this controller be ChecklistItemViewController? or GroupedChecklistItemViewController?
Finally, we have item and items in both areas… Instead of generic names I would go for more descriptive.
Hope this is useful… Lenny