RX swift Chapter 2- can't run, no permission?

Hi,

Have downloaded and built chapter 2 example, but when I try to run it I get an error.
“The file “RxSwiftPlayground.app” couldn’t be opened because you don’t have permission to view it.”
What am I doing wrong?

Using OSX 0.12.6 , Xcode 8.3.3.

1 Like

somebody already had that issue - they solved it by copying the unzipped folder to a different location on their computer, maybe give that a try?

Tried that, but it didn’t help. :frowning:

  1. Copied the project & run installed:
    tommy@MacBook-Pro:~/rxExercise$ cp -r …/Projekt/rxSwift/02-observable-pg/starter/RxSwiftPlayground/ .
    tommy@MacBook-Pro:~/rxExercise$ pod install
    WARNING: CocoaPods requires your terminal to be using UTF-8 encoding.
    Consider adding the following to ~/.profile:

     export LANG=en_US.UTF-8
    

    Analyzing dependencies
    Downloading dependencies
    Installing RxSwift (3.0.0)
    Generating Pods project
    Integrating client project
    Sending stats
    Pod installation complete! There is 1 dependency from the Podfile and 1 total pod installed.

    [!] Automatically assigning platform ios with version 10.0 on target RxSwiftPlayground because no platform was specified. Please specify a platform for this target in your Podfile. See https://guides.cocoapods.org/syntax/podfile.html#platform.

    [!] The RxSwiftPlayground [Release] target overrides the ALWAYS_EMBED_SWIFT_STANDARD_LIBRARIES build setting defined in Pods/Target Support Files/Pods-RxSwiftPlayground/Pods-RxSwiftPlayground.release.xcconfig'. This can lead to problems with the CocoaPods installation - Use the$(inherited)` flag, or
    - Remove the build settings from the target.

    [!] The RxSwiftPlayground [Debug] target overrides the ALWAYS_EMBED_SWIFT_STANDARD_LIBRARIES build setting defined in Pods/Target Support Files/Pods-RxSwiftPlayground/Pods-RxSwiftPlayground.debug.xcconfig'. This can lead to problems with the CocoaPods installation - Use the$(inherited)` flag, or
    - Remove the build settings from the target.
    tommy@MacBook-Pro:~/rxExercise$

  2. Then opened the project in Xcode and built it.(CMD+B)

  3. When I Run the project (CMD+R) I get message :

The file “RxSwiftPlayground.app” couldn’t be opened because you don’t have permission to view it.

So annoying!! :frowning:

Agreed, I personally am not a fan of playgrounds either … maybe the author of this chapter @scotteg has some recommendations how to battle this issue?

Hi @tsvensson, sorry you’re running into this issue. I was not able to reproduce it, but here is something you can try:

  1. Right-click on the main folder for the playground RxSwiftPlayground in Finder and select Get Info. You should see the following window:

  1. Change everyone to Read & Write.

54

  1. Click the lock and enter your admin password.

15

  1. Click the gear icon and select Apply to enclosed items…

30

  1. Then try to build again. You should also select a simulator instead of a device before you build, to avoid getting the Failed to read Info.plist of app error.

40

Let me know how it goes. Thanks!

1 Like

Sorry, but changing the file permissions didn’t solve the problem.

Well, think I just continue reading the book without doing the exercises.
Dont feel like spending any more time to solve this.

It happened to me too. Changing permission and enclosing doesn’t fix the issue

This topic was automatically closed after 166 days. New replies are no longer allowed.