ProBuilder Tutorial: Rapid Prototyping in Unity |

ProBuilder is a Unity in-editor prototyping tool that has everything you need to block out your level and create new game worlds in the blink of an eye. This tutorial will teach you the basics of how to use it.

This is a companion discussion topic for the original entry at
1 Like

Unity console:
Library\PackageCache\com.unity.settings-manager@1.0.0\Editor\UserSettingsProvider.cs(413,84): warning CS0618: ‘InternalEditorUtility.RequestScriptReload()’ is obsolete: ‘RequestScriptReload has been deprecated. Use UnityEditor.EditorUtility.RequestScriptReload instead (UnityUpgradable) → [UnityEditor] UnityEditor.EditorUtility.RequestScriptReload(*)’

Thanks for that amazing tutorial,
But there is an issue on export part,when selecting Altar object,export option isn’t active,you can only export the childrens of this object one by one,which seems painful

Thanks you for reading the article! I’m glad you like it. Let me think. I’ve just tried it again and it was good. Make sure the Altar is currently selected and then check again. Or, check with a New Cube. You should be able to export almost anything. Check if it’s available on Tools > Probuilder > Export on the Unity topmost panel. Try reopening Unity. Please, let me know if this has been helpful. :grinning:

Hi, Jean. It seems a Unity problem. Were you able to solve it?

Glad you are following my query dear Mauro,actually i will record a video and upload it to youtube in order to show you to issue in detail.

1 Like

Kindly check this video demonstration for more details:
i hope the quality is already fixed by youtube as it’s recently uploaded and not yet improved to HD

Excellent! Now, that’s weird. I’ve noticed that you are using Unity 2020.3 :face_with_monocle: and ProBuilder 4.5; newer version than ours (at that time). I will try to Upgrade my personal project to see if I have the same problem. Let’s tackle the challenge! :sunglasses:

Done. Unity has changed the workflow for the new versions. You cannot export a GameObject that hasn’t got ProBuilder MeshFilter. In the case of a parent GameObject, you cannot export anything.

So, you can do three things to solve it:

  1. Create a new common Cube and Probuilderize it (just disable the Mesh Renderer)

  2. Directly create a ProBuilder Cube

  3. Create an empty and add the ProBuilder MeshFilter

Then put all children inside.

Now, the Export button should be available.
Let me know if it works for you. :smiley:

Thaaanks,it works! :smiley: :smiley: :smiley:
Wish best luck for me in learning path dear

Thanks for reply, I’ve solved that issue.