Group Group Group Group Group Group Group Group Group

Problem with Chap 10

When I started using the starter for Chap 10 it get 18 error messages like ‘Scene’ is only available in macOS 11.0 or newer’. I get 18 messages like this. I opened Chap 11 and get the same messages. I think it is obvious that earlier chapters worked.

Hi @marvmax , make sure you’ve selected the iOS target image

That screen shot looks like it comes from my computer because I’m having trouble with WelcomeView() as well. On my computer it looks like the iOS target is chosen. I do go in and choose it again and do a build and all the error messages go away. Then I commented out WelcomeView() and tried to see a preview then all of the errors came back.

So you’re saying that after building it resets to the macOS target?

I’ve take some screen shots. It looks like the iOS target is picked in all cases, unless I’m missing something. When I highlight the iOS, instead of assuming that it is picked, and do a build the error messages go away. When I try to preview a view, in this case settings, all the errors came back

It looks like you’re still using the macOS target

image
image

Make sure you select the iOS target from the scheme selector

image