Group Group Group Group Group Group Group Group Group

Podfile: RealmSwift version

#1

When doing pod install I run into this:

[!] CocoaPods could not find compatible versions for pod "RealmSwift":
  In Podfile:
    RealmSwift (= 3.3.0)

Other than manually pulling version # out of the Podfile in each chapter+excercise before I pod install, is there a better way to do this, or am I hitting that error for some other reason?

#2

Hey Reez - Which chapter are you referring to? One with a sample project I assume?

Could you try two things?

  1. My initial hunch is that your local pod setup isn’t updated with the latest specs. The easiest way to fix this is running pod setup in a console. It takes a bit of time, so grab yourself a coffee in the meantime :wink:
  2. Regardless, we’ve released v1.1 of the book which fixes the playground issues users have, but also pops the version up to 3.4.0 - you might want to look into these as well.

If these two options didn’t help, let me know and I’ll try my best to assist.

Shai.

1 Like
#3

Cool I’ll check it out on v.1.1 now :+1:t4: