Group Group Group Group Group Group Group Group Group

Multiple commands produce '/Users/ error

I am a beginner with iOS, and I signed up to this program for help with CoreData. I am in the “Beginning Core Data” path, on lesson 10, “Core Data Stack”, and when I tried to build my project, I am getting this error:

Multiple commands produce ‘/Users/XXX/Library/Developer/Xcode/DerivedData/Reminders-SwiftUI-etzzrlkjabzfoncebbzwdzwvfbzm/Build/Intermediates.noindex/Reminders-SwiftUI.build/Debug-iphonesimulator/Reminders-SwiftUI.build/Objects-normal/x86_64/Reminder+CoreDataClass.o’:

  1. Target ‘Reminders-SwiftUI’ (project ‘Reminders-SwiftUI’) has compile command for Swift source files
  2. Target ‘Reminders-SwiftUI’ (project ‘Reminders-SwiftUI’) has compile command for Swift source files

I thought this might be a problem with the Signing & Capabilities, so I added my account, but that didn’t clear it up. I checked on Stack Overflow, and I followed the suggestions below, they didn’t work (except that there was no info.plist file listed in the area indicated, to clear our). I searched the forum here, and while one other user reported the issue, he reported it resolved before he got any suggestions as to how to fix it. I have shut down and restarted multiple times, and I have cleared out the project with “cmd+shift+alt+k”.

Any suggestions on how to get rid of this error so I can continue? Thanks.

https://stackoverflow.com/questions/50718018/xcode-10-error-multiple-commands-produce

Hi and welcome to the forum community @dumbbunny! I’d like to see if I can reproduce the issue you are having however I am not certain of the exact tutorial you are referring to. Is this the current course you are on? Beginning Core Data | raywenderlich.com

Best,
Gina

Hi Gina - yes, that is the lesson. I started with the shell project in lesson 6, and now I am in lesson 10, and I’m running into this stumbling block. I appreciate your help, as I don’t think this has anything to do with the actual code.

It is hard to tell where exactly the problem is; i’ve uploaded it to GitHub, if that is helpful. I’m not very good at GitHub, but I believe this should give you access.

Thank you for sharing your project. What seemed to work for me was deleting the xcdatamodel file from Compile Sources under Build Phases and project target. I had also deleted the items in Copy Bundle Resources but not sure if that was necessary. Below is the link I referred to when troubleshooting and an image for the answer I had tried.

Source: info.plist - Xcode 10 Error: Multiple commands produce - Stack Overflow
Image of answer from source: Screen Shot 2021-01-11 at 7.53.52 AM

Best,
Gina

Thanks - that seems to be working. I’m not sure how that got there, but thank you for identifying the source of the problem.

1 Like