Group Group Group Group Group Group Group Group Group

Improving Accessibility in Unity Games – Part 2 | raywenderlich.com

In Part 2 of Improving Accessibility in Unity games, you’ll add support for motor and cognitive disabilities and add some options to help guide players.


This is a companion discussion topic for the original entry at https://www.raywenderlich.com/5783534-improving-accessibility-in-unity-games-part-2

I’m having trouble implementing the FPSController accessibility; I used

using UnityStandardAssets.Characters.FirstPerson;
public RigidbodyFirstPersonController rigidbodyFirstPersonController;

just like in the tutorial, but when I try to select or drag RigidBodyFPSController from the hierarchy, nothing changes; the field in the inspector stays like this

None (Rigidbody First Person Controller)

Hi jc10487,
Thank you for your question.

I’ve just tried to replicate your issue using the project files from the tutorial and updating to the latest version of Unity. Connecting up the RigidbodyFirstPersonController seems to be working fine for me.
The fields you have added to the Settings Controller look correct, and the field has appeared in the Inspector as you would expect… So that rules out a few potential problems.
One thing to try:
If you click on the little connection circle at the end of the inspector field what do you see?
InkedImprovingAccessibilityquery1

Making sure scene is selected. Can you see and manually select RigidbodyFPSController?

InkedImprovingAccessibilityquery2

Please let me know if you are seeing something different or whether manually selecting in this window does not complete the inspector field.

I do occasionally find that Unity misbehaves in the strangest ways, sometimes it just needs to be closed and restarted, or updated to fix the odd little bug.

let me know how you get on.

Mark :]

Hi Mark,

Thanks for the reply. So I see everything you mentioned, except that when I select “RigidbodyFPSController”, the field doesn’t change, i.e. I can’t select it. As long as I use

using UnityStandardAssets.Characters.FirstPerson;
public RigidbodyFirstPersonController rigidbodyFirstPersonController;

I shouldn’t have this problem, right? I checked to see that nothing else in my project had it selected already, or that anything would conflict with it, so I’m not sure what my problem is.

Nvm, I found the problem; I had two copies of RigidbodyFirstPersonController.cs in two separate folders (idk how that happened), so I deleted one of them and everything works now.

Hi! I’m glad you figured it out. Good sleuthing!
That is not a problem I’ve had, but it’s definitely something I’ll consider when things start behaving oddly. Thank you for answering your own question! I’ve learned something new here, and perhaps others will too :+1:

1 Like

This tutorial is more than six months old so questions are no longer supported at the moment for it. Thank you!