Group Group Group Group Group Group Group Group Group

Chapter 4 - "Error returned from daemon: Error Domain=com.apple.accounts Code=7 "(null)"" completed photo selection

Hi,

“Error returned from daemon: Error Domain=com.apple.accounts Code=7 “(null)”” completed photo selection

I’m getting this error in both the starter and final projects,
this happens every time I’m in PhotosViewController and tap on a photo.
nothing is displayed in the MainViewController.imagePreview.

Thanks.

I have been getting this message consistently in my applications that use the Photos framework (import Photos). It does not seem to impact functionality of the apps. I see it when running on the Xcode simulator and when running on actual devices and in both production Xcode and Xcode Beta 6.

Just for fun I took a look at the runtime console log for a Photos app (PhotosDisplay) I designed while running on an actual device (iPhone X iOS 13.7).

The iOS system program accountsd logs “Unentitled access by client PhotoDisplay…”
And then PhotoDisplay logs “Error returned from daemon: Error Domain=com.apple.accounts Code=7”

While this does not answer what exactly is going on it does give some context that it is pretty deep in the framework and probably not something we can control.

Tom

Hmm, I got to say I’m not quite sure what the reason might be for this error message; it does look like something that’s an issue on the side of the Photos framework rather than Combine. If you figure it out please chime in this thread so we can track it - I’ll keep an eye and if other readers also report similar experience I’ll cross-post here.

Hi, @andreskwan have you been able to resolve this issue? I am facing the same issue and can’t seem to get past it. Please let me know if you have a solution.

same problem here. i couldn’t find answer

@andreskwan @adamsmorgantom @black_snow @odyflame Do you still have issues with this?

I don’t have the RW code handy but I just tried one of my Photos apps and still get the message

" [core] “Error returned from daemon: Error Domain=com.apple.accounts Code=7 “(null)””" when accessing photos from either a simulator or iPhone X hardware.

Hi! What I did was to work with images (I added them), no photos taken with my phone’s camera, I think it could be related with the format of the photo, I also turned off ‘Live’.

Hey guys I am also getting this error message, any fix for this?

I also got this issue even with the updated Xcode ver 13.0 and iPhone 12 mini (iOS14.7.1). If anyone solved, kindly let me know your solution.