Group Group Group Group Group Group Group Group Group

Chapter 15 Moor has been renamed to Drift

Is there a plan to migrate to drift?

Got the following error

charlesyeh15@Charless-MacBook-Pro starter % flutter pub run build_runner build --delete-conflicting-outputs

[INFO] Generating build script…

[INFO] Generating build script completed, took 551ms

[INFO] Initializing inputs

[INFO] Reading cached asset graph…

[INFO] Reading cached asset graph completed, took 106ms

[INFO] Checking for updates since last build…

[INFO] Checking for updates since last build completed, took 906ms

[INFO] Running build…

[INFO] Running build completed, took 30ms

[INFO] Caching finalized dependency graph…

[INFO] Caching finalized dependency graph completed, took 70ms

[SEVERE] json_serializable:json_serializable on lib/network/recipe_model.dart (cached):

The version constraint “^4.1.0” on json_annotation allows versions before 4.3.0 which is not allowed.

[SEVERE] Failed after 116ms

pub finished with exit code 1

charlesyeh15@Charless-MacBook-Pro starter %

Hi.

Did you try to downgrade packages ?

olivaxa

Thanks for suggestion.

The app works now; I used package settings in final version of the code:
flta-materials-editions-2.0Flutter Apprentice/15-saving-data-with-sqlite/projects/final

image

I have the same packages of moor defined in pubspec.yaml:

moor_flutter: ^4.0.0
moor_generator: ^4.4.1

When running: flutter pub run build_runner build --delete-conflicting-outputs
I get this error related to version 4.6.1 (although 4.0.0 is defined in dependencies)
Error when reading ‘/X:/apps/flutter/.pub-cache/hosted/pub.dartlang.org/moor-4.6.1+1/lib/src/runtime/executor/stream_queries.dart’:

This error makes sense since in the folder … moor-4.6.1+1\lib\src
there is only one file: deprecated.dart, containing only a const telling moor was renamed to drift … and no other files at all, there seems to be some package management problem if I am not wrong

Look like they are replacing Moor with Drift for chapter 15.

Any link to updated chapter 15 using Drift?