Group Group Group Group Group Group Group Group Group

Chapter 11: package is using Swift tools version 5.4.0 but the installed version is 5.2.0 docker

Hi everyone, I’m trying to run this command in terminal; docker-compose -f docker-compose-testing.yml up --abort-on-container-exit. Everything looks fine but except I have an error package is using Swift tools version 5.4.0 but the installed version is 5.2.0. However, if I do not use 5.4.0, unfortunately I can not use the schema in xcode, weird actually :smiley:


Also these are my configure file and docker-compose-testing.yml file Screen Shot 2022-01-06 at 03.43.20

Your Dockerfile probably starts with something like FROM swift:5.2 - change that to FROM swift:5.4 to use a newer version and it should work fine

Hi actually my Dockerfile starts with swift:5.5. If I downgrade the version. Can be solve it? Here is the ss;

That’s not the testing.Dockerfile the compose file is pointing at though is it?

I got you now. Thank you so much. Another question is

Is it related about the test functions ? I got failed some test cases.

What’s above that? It looks like there’s an error somewhere but hard to tell what it is. My suggestion would be to ensure you delete all the docker containers, remove .build, make sure everything is up to date with swift package update and then try again