Your First iOS App - Part 48: Conclusion | Ray Wenderlich Videos

Let's review what you learned in this course and discuss where to go from here to continue your iOS learning journey

This is a companion discussion topic for the original entry at


Building on my device (iPhone 6s plus) does not transfer the app’s icon to the device.
Is that normal?

Thank you
Please assume that all the icons necessary are there.

We’ve been in touch with this via email, but for anyone else wondering I tried the installing the app on my iPhone 6s and it worked OK for me, so this isn’t expected behavior. I’m not sure if you ever got this working @notationmaster?

In the end it did.
Tried a few days later and it just worked.

Thank you for your assistance

Is there any download link to the files used in this tutorial?

@kwatkins You can download the files for each video using the Download Materials button.

Hi Ray,
Thank you so much for this course. I read books over Swift and also watched other tutorials for beginners, but this is really great! Even if it is only a simple App it touches lots of Xcode handling and Swift programming concepts. And in the end I have a running App!

One thing does not work on my Xcode 10.2.1 this was the WebView. I always got an error when running the App and clicking on the info button. I tried this on my iMac with Xcode 10.1 and there it works. Maybe the WebViewKit has changed slightly.

I saw the same thing, I had add the WebKit framework. To do this:

Choose Project navigator (little folder icon in the upper left corner)
Choose your Xcode project (the blue icon not the yellow folder)
Choose Build Phases
Choose Link Binary with Libraries > Click + sign
Type Webkit and click Add

Then give it another try. Hopefully it will work for you :slight_smile:

1 Like

Thanks jlucia, that worked for me as well. :smile:

Thanks , I just finished the whole series. To be honest I am not a beginner but I thought I’d watch this as a refresher.
More videos please on any topic


I’m having a small issue, where when I test the app from within Xcode, everything functions as expected. I copied the app to my iPhone 7Plus, the app will load and let me play through a few rounds, even reset my counters, however, if I try to click on the information button, the whole app crashes. I reloaded it in Xcode, loaded it to an iPhone 7Plus simulator, for completeness, and it worked fine there, even tried restarting my phone. Has anyone else had a similar problem?

@rspishock Do you still have issues with this?

Yes, I’ve removed it from my phone and copied it back over several times but with no success.

The reason is Webkit.framework is not incluided in the build, Go to Project Section (where you change display name) then search “Linked Frameworks and libraries” section, press plus button below, search for “webkit” select “Webkit.framework” and the press Add. (this framework now will be on the list).

Rebuild project, and thats all

@elporfirio Thank you for sharing your solution - much appreciated!