Group Group Group Group Group Group Group Group Group

Your First iOS and SwiftUI App · Conclusion | raywenderlich.com


This is a companion discussion topic for the original entry at https://www.raywenderlich.com/4919757-your-first-ios-and-swiftui-app/lessons/48

Yaaah I did it :tada::tada::tada: My 1st iOS App using swiftUI and it’s working :grin::laughing: .
Thanks A lot @rwenderlich You are a great teacher.

1 Like

w00t you did it! Congrats for making it all the way through the course @ekramy, and thanks for sharing the screenshot!

I’d bet most iOS developers haven’t gotten too far with SwiftUI yet as it’s still early days, so you’ve got a nice head start! :]

Thanks, @rwenderlich for your nice words. You have excited me to continue.:grinning:

Woohoo! Thanks for this course. Just finished it and it feels good!

Congrats Michelle! :smiley:

@rwenderlich Tank you so much … I finished this Free course on SwiftUI and Xcode the Bullseye and I just feel great … I did learned a lot your methods of teaching so easy to follow and most importantly so fun … Thank you for a great course

I learnt a lot. Ray you really are an incredible instructor. I complete the course in a couple days and I understand every word that came out of your mouth. Cant wait to subscribe.

Love the course. Unfortunately, when I downloaded the app onto my phone it blacks out the buttons. Did anyone else have this issue?

It shows up completely fine on the preview on all devices.

I have the following screen shots.

Any help would greatly be appreciated!

Hooah, made it through the first one (with frequent pausing as I’m slow ). One quirk I found was in the simulator the “Info” screen would only show up once, never on subsequent pressing yet it worked fine on my physical phone.
Very good tutorial! Starting the next one.

It looks like you’ve doubled the modifiers on the buttons. I show having just the “Shadow” modifier on the button itself, but the Large/SmallTextStyle modifiers go on the Text object.
Like: Text(“Start Over”).modifier(ButtonSmallTextStyle())
So move the text modifiers from the button to the text objects and you should be ok.43%20PM

@nakolody Do you still have issues with this?

I got it. Thank you so much for the help! Appreciate the responses!

Awesome course. Thanks.
Did you notice that in the simulator, you can navigate to About Bullseye and back once, but after that, hitting the Info button does nothing?
On the device it works fine.
Seems that this is an Xcode bug?
Similar to here:

I did notice that too. I think it might have something to do with bringing it to the front on subsequent iterations? Not sure.

I really appreciate you. There was no good site for iOS app but I found it! I was a little hard because it’s english class, but I tried with repetition and I did it! I’m so happy now. If I get job and money, I’ll come back to subscribe and take another class! Thanks a lot :smiling_face_with_three_hearts::smiling_face_with_three_hearts::smiling_face_with_three_hearts:in Korea :kr::kr:(I’m sorry if my english skill make it hard to understand :joy:)

@lgoudge @slogbelly This is a SwiftUI bug that has been fixed in Xcode 11.4. Thank you!

@zzompang2 Really glad you like it! Cheers! :]