Xcode 9 will not save my Simulator choice

Version 9.2 (9C40b)

Older versions of Xcode would save whichever Simulator I had chosen to run my app. Now, I have to reset the Simulator choice every time I open Xcode. Is there a fix?

Hi @7stud, thank you for reaching out. Unfortunately I do not know if there is a fix but what I generally do is keep the simulator open and hidden even if I quit Xcode. That way if I re-opened Xcode the simulator would remain the same.

Best,
Gina

Hi,

Thanks for the response. Your suggestion doesn’t work for me. Whenever I open Xcode, the Simulator choice always defaults to iPhone 8 Plus–no matter what simulator is currently open.

Hi @7stud, there is a chance it could be a bug. It might not hurt to make a report to Apple, https://developer.apple.com/bug-reporting/ . I am using Xcode 9.2 and am not experiencing the issue you are having. I apologize that I cannot provide a solid solution.

Best,
Gina

Yes, this is so annoying with the latest XCode! Someone found a weird workaround that seems to do the trick :

  1. Open your project
  2. Choose the simulator you’d like to be the default
  3. Open your Scheme settings (Product > Scheme > Edit Scheme)
  4. Close your Scheme settings window (you don’t need to change anything)

This workaround only works per project so you have to do it once per project you’re working on.
Happy coding :slight_smile:

Edit : Thanks @sgerrard for the simpler process!

Alright! Thanks mbritto. For anyone else:

In Xcode, look up at the menu bar:

Product > Scheme > Edit Scheme

In the Info tab, I changed the Build Configuration from Debug to Release, then I clicked the Close button to save the setting, then I chose the Simulator I wanted (to the right of the button you click to run your project), then I closed the project.

I discovered the Edit Scheme trick some weeks ago. I have since found that you don’t even have to change anything. With the project open and the desired simulator selected, just click Product > Scheme > Edit Scheme…, then click Close on the form that appears.

I now do this as part of my standard sequence when opening a project for the first time.

1 Like

This topic was automatically closed after 166 days. New replies are no longer allowed.