Group Group Group Group Group Group Group Group Group

Workspace does not exist

#1

I’m following this in every chapter,

“To get started, open the macOS Terminal app (or another similar app of your choice), navigate to the current chapter’s starter folder, and run the bootstrap script:”

and running into this every time:

xcodebuild: error: 'RealmPlayground.xcworkspace' does not exist.

I “get” the error (I need an .xcworkspace, and I could get one via CP or whatever), but I’m trying to understand if there is some step I’m missing from the book that is unwritten?

#2

Hi @reez, at what step in your process does this error occur? I tried Chapter 3 and was able to get the starter project to the “Ready to Play” in the debug console. Here are steps I took:

  1. Opened terminal and went to Realm Resources Folder -> Chp3 Folder -> then the “starter” folder.
    59%20AM
  2. Once I was at the starter folder I entered “./bootstrap.sh” and hit enter.
  3. I saw this, indicating that the bootstrap process was working. And it did take some time to process.
    20%20AM
  4. After it completed, Xcode automatically opened the starter project and from there I was able to open the debugger to view the “Ready to play…” .

Let me know if this helps you, if not, let me know what steps you’re taking and hopefully we can get this resolved.

Best,
Gina

#3

Like @gdelarosa - Things look well on my end, but we’ve also just released a new version of the playground and playground bootstrap script, please check those out as I believe they will resolve all of the issues you might be having.

#4

Sure, chapter 3 (and others) in v1.0 did not have an .xcworkspace (and the bootstrap script did not create one for me). Chapter 3 in v1.1 does have an .xcworkspace now (before any bootstrap script gets run), so that answers my Q and takes care of this specific error.

Your using the updated v1.1 now I’m assuming when you just did your steps ya?

#5

I believe that the v1.1 addition of the .xcworkspace in the initial files was meant to take care of this ya?

That was the crux of the error for me

#6

I believe I was using v.1.0 after checking my folder since I didn’t know about the update. However, I’m glad v1.1 is working out for you!

#7

Got it, I checked my v1.0 and it wasn’t in there for me, but maybe it was in there for you! Anyway, thanks!

1 Like