Video play button not showing

Hi Im on annual subscription
and all of a sudden all videos don’t have play button!
As such I can’t watch any tutorials.
I’ve tried on both Chrome.
I tried it on Safari, but for some reason the login page goes to 505 error.
How do I fix this?

Hey, have the same problem. Hope to find a solution.

I had the same problem some time ago and saw a FAQ entry

https://help.raywenderlich.com/faq

with the title “I’m having trouble watching a video, what should I do?” And that had a solution. I recall following their fix and that it worked. I just don’t remember what I did…

Unfortunately the link gets a 404 Error today.

It think it had to do with rebooting and/or clearing the browser cache for at least a few days prior.

Thanks for letting us know about this issue and giving us the chance to help sort it out! I am not able to find the same issue, but the good news is that this is likely a local issue we can help sort out with a few steps. Can you please try the following steps to help sort this:

  1. Try a different browser and see if you’re still seeing the same error (try Chrome, Firefox, or Safari if not already using one of these)

  2. Can you please try playing a different video and see if it’s all videos or just the one video erroring?

  3. Try to open the same URL in a private or incognito window. To do this, right-click on your browser icon and click to open either an incognito window or a private browsing window (depending on your browser).

  4. Navigate to the same URL and try playing the video again after logging into your raywenderlich.com account.

  5. Double-check that you have Javascript enabled on your browser by clicking through to this tab (if it isn’t, enable it according to the instructions there).

  6. Disable any browser plugins that can block content (ad-blockers sometimes do this even though our videos don’t contain ads, for example).

  7. Take a look at the JavaScript console for your browser (if you’re unsure how to do this please check this guide here) Take a screenshot of any errors (usually in red) and send them to us.

  8. If you’re still seeing issues, please go to this site to perform an internet speed test and then send us the link you’ll receive on completion of the test.

If you’re still seeing problems after trying the above, though, please fill out this form here that will ask for all the top details needed to investigate? Once we have the report I’ll follow up on that email directly and we’ll get this feature working for you again.

This can take a few days as we work between the teams, but I’ll be sure to update you on the outcome no matter what.

Thanks for your patience while we sort this out!