Group Group Group Group Group Group Group Group Group

Source code for Xcode 10 and Swift 4.2?

#1

The advertisement of the book doesn’t say which versions it supports. Having good faith on this website I purchased the book and only after that I found out it was for older versions of Xcode, Swift and Realm. Accompanying source code doesn’t work obviously for me on Xcode 10 and Swift 4.2.

This is so annoying. If it was clearly indicated before purchasing the book, I would not have bought it.

Now what do I do? Can I get source code for latest versions?

#2

I updated the Realm to its latest version. Now the Chapter 2 projects compile and work, with some warnings. But I guess I can continue and hopefully this will work throughout the book.

#3

The latest version of the book is for Xcode 9 but if you purchased through the online store you can get a refund if you contact support in a timely manner.

#4

I went over some other answers here. What I understood is that I’ll get updated versions of the book and the code around autumn. If this is correct then I don’t see a need to return it.

#5

Please advise whom to contact if to return this book?

This book is absolutely not ready for Xcode 10 and Swift 4.2 whereas it has not mentioned this anywhere in the book store or the post I got its link from. I can’t run anything from chapter 3 after wasting almost my all day.

Here are the references which lead me to this book:

https://www.raywenderlich.com/9220-realm-tutorial-getting-started
https://store.raywenderlich.com/products/realm-building-modern-swift-apps-with-realm-database

Please clearly update on these links that this book is for Xcode 9 and Swift 4.

I now notice a small blurry print of the book cover which mentions it, but it is almost not noticeable.

#6

As said previously, the current version of the book is for Xcode 9. If you’d like to get a refund, please contact: support@razeware.com