No such module ‘RxSwift’

None of the solutions mentioned in the various threads on this topic have worked for me, but I have found a workaround. I just created a new project using CocoaPods to install the RxSwift dependencies, and imported the playgrounds for the book. For some of the playgrounds, ex g chapter 11, you do need to make sure that “Build active scheme” is selected. Hopefully this will help some of you having this problem.

Hi, for clarity purposes and for the author’s benefit, could you mention the particular problem to solve? The comment jumps right into a solution, but the question isn’t clear.

Sorry, I probably should have made it clearer in the title, but I’m referring to the “No such module ‘RxSwift’” error, which many people seem to have when trying to run the playgrounds.

1 Like