Networking with URLSession - Part 9: ATS | Ray Wenderlich

Learn what your app needs to do, to support Apple's requirement for App Transport Security.

This is a companion discussion topic for the original entry at

Hi, audrey, hope you’re not tired of my endless problem. :stuck_out_tongue:
In this demo, I tried to add this line $SRCROOT/BuildPhases/ directly into Build Phases->Run Script, but failed with a build error, saying that “xxxx: No such file or directory”.
I guess that’s caused by some spaces in my project path. Maybe there’s a little bug in the shell?

PS: I also tried to paste all the script into project, and it works fine.

1 Like

Hi calios, I’m always happy to see what you all are doing :+1:

Possibly the script expects no spaces. Pasting the script directly into Xcode is the easiest option, but I showed the way described in mokagio’s post: inserting it in a way that the source control can track changes, and the team can easily code review it. Unless/until these things concern you, it’s fine to just paste in the script.

Hi @audrey,

I also faced the same issue as @calios and solved it by double quotes.