Group Group Group Group Group Group Group Group Group

Multiple commands produce...warning: duplicate output file

Hello everyone, I need help with that message :

Multiple commands produce ‘/Users/username/Library/Developer/Xcode/DerivedData/myApp-cqsvatsweajrlwgztrbdqodhawmh/Build/Products/Debug-iphonesimulator/myApp.app/Info.plist’:

  1. Target ‘myApp’ (project ‘myApp’) has copy command from ‘/Users/username/Documents/Custom-Projects/aFolder/myApp/myApp/Info.plist’ to ‘/Users/username/Library/Developer/Xcode/DerivedData/myApp-cqsvatsweajrlwgztrbdqodhawmh/Build/Products/Debug-iphonesimulator/myApp.app/Info.plist’

  2. Target ‘myApp’ (project ‘myApp’) has process command with output ‘/Users/username/Library/Developer/Xcode/DerivedData/myApp-cqsvatsweajrlwgztrbdqodhawmh/Build/Products/Debug-iphonesimulator/myApp.app/Info.plist’

I think I did something wrong somewhere but I don’t know where.
I have a project with two targets, the difference between both are the name of the app and, of course, the info.plist.
Both targets compile fine till yesterday afternoon, one target compile fine but the other not with the following message:

I work with Xcode 11.x.x and with the new build system (not the legacy) and that for a long time.
I checked everything I can and finally, I restaured a copy of my app from TimeMachine but the probleme stay.

It seems the problem is not in my app but where ?
I would appreciatye if someone could help.
Thanks

@jean-michel Do you still have issues with this?

Hi shogunkaramazov, it’s a long time now, 29 days, I don’t remind exactly what happends but after searching here and there and didn’t find something, I decided to delete de whole app in Xcode and restaure it from TimeMachine.
The problem didn’t appear again. But I’m wondering what was the origin of that ?
Thanks for asking.

Hi @jean-michel,
It is difficult to ascertain the problem with just one error message. However Xcode and the various changing versions can create a problem. So if you clear the DerivedData and/or clear the project build files could many a times clear up some compiler problems with Xcode.

I had a jnr developer that had a problem, and could not find the issue, he simply deleted the repo and cloned the project again (totally random choice, many devs would continue to try to debug and find the problem) and it worked. No idea what the problem was, but it just worked.

cheers,

thanks jayantvarma, I did the same as your jnr developer and the problem disapeared.
Have a nyce day and take care.