Group Group Group Group Group Group Group Group Group

iOS 12 - Realm book - getting started with Playground in chapter 4

#1

I’m following chapter 4, I get the following error after running bootstrap.sh in the starter directory:

error: Playground.playground:24:8: error: could not build Objective-C module 'RealmSwift’
import RealmSwift

This obviously is a podfile problem, when I look for podfiles:

$ find . -name “Podfile”

./BackLinks-challenges/Podfile
./starter/Realm/examples/installation/watchos/swift/CocoaPodsExample/Podfile
./starter/Realm/examples/installation/watchos/objc/CocoaPodsExample/Podfile
./starter/Realm/examples/installation/osx/swift/CocoaPodsExample/Podfile
./starter/Realm/examples/installation/osx/objc/CocoaPodsExample/Podfile
./starter/Realm/examples/installation/ios/swift/CocoaPodsExample/Podfile
./starter/Realm/examples/installation/ios/objc/CocoaPodsExample/Podfile
./starter/Realm/examples/installation/ios/objc/CocoaPodsDynamicExample/Podfile
./starter/Realm/examples/ios/objc/Podfile
./BackLinks-final/Podfile
./BackLinks-starter/Podfile

I’d assume running bootstrap.sh would build this, but it’s not. What Podfile do I add RealmSwift in? Or am I doing something completely wrong?

#2

Had to change bootstrap Realm version to
REALM_VERSION=“3.13.1”

#3

@dskjflksjadlkfj Glad you fixed it! :]

1 Like
#4

I didn’t find the REALM_VERSION in bootstrap,I only change pod but no use

#5

@bubble Do you still have issues with this?