Group Group Group Group Group Group Group Group Group

HTC Vive Tutorial for Unity | raywenderlich.com


#1

Learn how to use the HTC Vive with Unity! Grab and throw objects, shoot lasers and teleport around an area.


This is a companion discussion topic for the original entry at https://www.raywenderlich.com/9189-htc-vive-tutorial-for-unity

#2

Hello! I’ve just joined, and I’m looking forward to going through the Vive tutorial. I downloaded the materials, but there’s a problem: the Game scene shows up empty, just a blue environment. When I open the “objects” tab in the hierarchy, all the items inside show up as “Missing Prefab”. This is the same in both the “Starter” and “Finish” versions of the project. Am I missing some assets, or do I need to do some preliminary setup in order to view the scene? Please advise. Thanks!


#3

Hi!

That doesn’t seem right.
What version of Unity are you using? I’ve tested with both 2018.2 and 2018.3 just now and they both work fine.
It sounds like the 3D models aren’t importing correctly. Try right clicking the models in the RW \ Models folder and selecting Reimport, do they load up fine after that?

Cheers!


#4

Thanks for the response! I’m using Unity version 5.6.3. Reimporting those models doesn’t solve the problem for me, I’m afraid.


#5

Upgraded to 2018.3 and the assets some through fine. Thanks for the assistance!


#6

Hi there, Thanks a lot for the tutorial!!!

I have only one question about the last part. For the laser pointer ‘Teleport Mask’ I cannot see the option for ‘CanTeleport’. Did I miss a configuration?


#7

@blackdragonbe Can you please help with this when you get a chance? Thank you - much appreciated! :]


#8

This needs to be added to the tutorial for 2018.3

Open the Package Manager (Window->Package Manager), select “OpenVR” in the package list and click install. Restart Unity


#9

Also the STEAMVR for unity 2018.3 can be found here:


#10

Hey, thanks for the help mate.

I’ve reinstalled the package and plugin, restarted the system but the ‘CanTeleport’ option still not available.

Once I try teleporting in game, it is very weird. I will keep trying to fix it, I might have missed something simple.


#11

Hi!

CanTeleport is a layer that I included with the project. I know Unity likes to remove those after some version upgrades.
Can you check if the CanTeleport layer exists in the Edit > Project Settings > Tags and Layers menu? It should be assigned to “User Layer 8”. If it’s not there, fill in the text field next to User Layer 8 with CanTeleport.

The OpenVR package isn’t necessary to follow along with this tutorial, all you need is the most recent version of SteamVR from Github or the Asset Store.

Let me know if you have any questions or issues.

Cheers!
Eric