Get Started with Flutter | raywenderlich.com


This is a companion discussion topic for the original entry at https://www.raywenderlich.com/13739693-your-first-flutter-app/lessons/4

Hello,

As of 12/26/2020 I had to add a main() function at the top of main.dart to get the initial screen for Bullseye to work.

void main() {
    runApp(BullseyeApp());
}

flutter doctor output

Flutter (Channel stable, 1.22.5, on Mac OS X 10.15.4 19E287 darwin-x64, locale en-US)

Thanks

Hello,

07/08/2021

When I tried to run “flutter pub get” for the first time I got this error message:

"pubspec.yaml has no lower-bound SDK constraint.
You should edit pubspec.yaml to contain an SDK constraint:

environment:
sdk: ‘>=2.10.0 <3.0.0’

See The pubspec file | Dart
Running “flutter pub get” in BullsEye…
pub get failed (65; See [look the last url])"

I googled that message and I found this:

So, I added the constraint to the end of my yaml file and now it’s working, but I want to be sure that was the right way to go.

Thanks.

Hello,

07/10/2021

When I ran “flutter create .” command for the first time I got this error message:

“BullsEye” is not a valid Dart package name.

See The pubspec file | Dart for more information.’

I took a fast review to the suggested documentation and changed the package name to: “bulls_eye” in my yaml file.

Then, ran the “flutter create .” command again and the terminal showed the same error message, so, I google it and found this:

Finally, changed the project’s folder name to: “bulls_eye” and now I’m able to create the app.

This is the Flutter doctor output:

Flutter (Channel stable, 2.2.3, on macOS 11.4 20F71 darwin-x64, locale es-419)

I hope this will be useful for someone.

Bye!

i have that and it fail just the same

i tried with this and it work:

flutter create . command not working i get this error Bulls_Eye" is not a valid Dart package name how do i fix it