Framework was built without full bitcode - Framework bitcode already enabled

Hello, have been struggling for few days… Basically I have build a compiled released framework and distribute it with cocoaPods. The problem is that then archiving this framework application gets the following error:

ld: bitcode bundle could not be generated because ‘/Users/apple/Desktop/testingPodsAcrossversions/Pods/Pod/Pod.framework/Pod’ was built without full bitcode. All frameworks and dylibs for bitcode must be generated from Xcode Archive or Install build file ‘/Users/apple/Desktop/testingPodsAcrossversions/Pods/Pod/Pod.framework/Pod’ for architecture arm64

I have did these things:

** Search for Enable Bitcode setting and set it to YES for Debug and Release modes.

** Search for bitcode settings. Add -fembed-bitcode in both Debug and Release modes or you can add -fembed-bitcode-marker in Debug and -fembed-bitcode in Release mode.**

Add BITCODE_GENERATION_MODE under User Defined setting , and then add bitcode for both Debug and Release modes or you can add markerin Debug and bitcode in Release mode.

I only need release version, so I did not built an universal framework, just release version… I would genuinely like to solve this issue, because it has been a nightmare for me…
Also other people are getting this error, we need to solve this problem once and for all!


@raywenderlich Ok, I am really depressed… why nobody helps??? here is more detailed info:

Hi @wellbranding, sorry to hear that you are having a hard time resolving this issue. I can understand the frustrations. I’m not 100% sure how to solve this issue because I personally have never come across it but I’d like to provide a suggestion. Have you tried setting the skip install to NO? Then export the archive to the framework.

Best,
Gina

This topic was automatically closed after 166 days. New replies are no longer allowed.