Group Group Group Group Group Group Group Group Group

raywenderlich.com Forums

Firebase Tutorial for Android: Getting Started

In this Firebase Tutorial for Android you'll learn how to work with Reatime Databases and Authentication by creating a Joke Telling app.


This is a companion discussion topic for the original entry at https://www.raywenderlich.com/5114-firebase-tutorial-for-android-getting-started

Hi. I really like the topic. When can the starter project material be updated to support the gradle plugin 1.2.50 and higher?

@filbabic Can you please help with this when you get a chance? Thank you - much appreciated! :]

Hello @sk92129!

Yeah, Firebase is really fun to play with. :]

Currently, we always target the latest of tried-and-tested technologies in our tutorials, because it’s easier to relate to a bigger crowd of readers and people who want to try new technologies.

Having this said, I’m not sure if we’re going to update this to a lower version of Gradle.

Thinking about this, do you have any issues caused by the Gradle version?

Hey @sk92129, glad you like this tutorial!

If you’re referring to the Kotlin gradle plugin/version, we try to keep the latest versions when writing the tutorials, and as Kotlin is released, it’s a bit hard to follow up all the updates. :]

You can always update the versions yourself when you open up the projects, there shouldn’t be any breaking changes!

If you’re referring to the actual android gradle plugin, then 1.2.50 is a bit old, and as such we haven’t gone that far back. But if you’re using newer AndroidStudio versions, you’ll of course be prompted to update them when running projects.

Thanks for the feedback and the question, hopefully this resolves your concern.
Filip B.

I get this problem in the android studio and from the CLI:

The Android Gradle plugin supports only Kotlin Gradle plugin version 1.2.50 and higher. Project ‘Whysoserious - starter’ is using version 1.2.21.

I am bit confused by your reply.

Your whysoserious starter project is using version 1.2.21 of the gradle settings.

My gradle plugin says that it only supports kotlin gradle plugin version 1.2.50 and higher.

So, it seems your starter project files are old.

Yeah, I first thought you were mentioning the android gradle plugin (rather than Kotlin one).

But as I’ve mentioned, if it’s the Kotlin version you’re talking about, simply update the version to 1.2.50+, so that you don’t have problems. :]

This tutorial has been released quite a while ago, so, naturally, Kotlin’s version’s gone up.

Hi,

First of all, thank you for this guide, I’m still learning it.

But I have a request/question:
Do you have a similar exmple/app but not in kotlin? I need a similar implementation but in java.

Thanks.

@filbabic Can you please help with this when you get a chance? Thank you - much appreciated! :]

Hey @burekas

Sorry for the late reply, I though I had responded to your question, but something must have went badly. I have a personal learning project which I’ve built with FB. But it’s very outdated: https://github.com/filbabic/FirebaseChatApp.

Feel free to ping me with any other questions.

Dear Filip, It works! :slight_smile: Thanks for the tutorial.

This tutorial is more than six months old so questions are no longer supported at the moment for it. Thank you!