Firebase errors after installl of pods

Hi. I keep getting a ‘ugly red triangle’ message in app delegate. I did the suggested pod ‘firebase’ install and this is what I get.

error: linker command failed with exit code 1 (use -v to see invocation)
I hit a dead end at stackoverflow (although very helpful 99% of the time).

Any suggestions?
https://forums.raywenderlich.com/search?q=firebase

Could you post more details about the error? That’s a common log.

Sure. I tried installing Amazon Cognito Sync at first w/o success. I then tried installing pod Firebase. I keep getting two errors.

I mean errors by Xcode (if you open the error log it says more)

Here’s an xcode screenshot:

Yeah please click the error and focus on all the log

Try adding the following libraries in Frameworks
libc++.dylib, libiucore.dylib, CFNetwork.framework, Security.framework and SystemConfiguration.framework

(EDIT) Also you may want to do a clean to project after adding them.

libc++.dylib, libiucore.dylib are not available. This is what came up in search:

I think since I tried installing Amazon cognito, I’m running into overlapping pod files. I’m going to restart the project and add ‘pod firebase’ initially to the new ‘MyLocations’ template. Thank you for all your help.

libc++.tbd is fine instead of .dylib

Does ‘libiucore.dylib’ have a substitute?

Sorry it’s libicucore.dylib, or libicucore.tbd

I did everything you said to add to the new project. No errors. Woohoo! Now, however, it’s telling me I don’t have the GoogleServices-Info.plist in my project which I definitely do.

Any suggestions?

Why there is a (7) in the name? Also check out that it’s enabled to your app target.

It works! I can move on. Thank you so much for clearing my 8 hour speed bump.