Group Group Group Group Group Group Group Group Group

Error - Flutter JNI

Hi,

Please help…thanks in advance…

I started getting this error only after I upgraded to Flutter2.5.0
…any resolution to this error?.

WITH/Flutter JNI(26700): Tried to send a platform message to Flutter, but FlutterENGINE was detached from native C++. Could not send. Channel: activity_recognition flutter. Response ID: 0

In which chapter is this happening?

Hi @funkyboy
thanks for your reply…
this msg starts appearing when I create any new project and remains on and off in my Debug Console (using VSCode as the editor). Sometimes it goes away by itself but comes back when I re-build the projects. This msg does not cause any crash or any problem (I guess) to my app so I don’t know whether its just a “msg” or an “error”.
I am posting my environment as follows

[✓] Flutter (Channel stable, 2.5.0, on Mac OS X 10.15.7 19H1417 darwin-x64, locale en-SG)
    • Flutter version 2.5.0 at /Users/xm/development/tools/flutter
    • Upstream repository https://github.com/flutter/flutter.git
    • Framework revision 4cc385b4b8 (12 days ago), 2021-09-07 23:01:49 -0700
    • Engine revision f0826da7ef
    • Dart version 2.14.0

[✓] Android toolchain - develop for Android devices (Android SDK version 30.0.3)
    • Android SDK at /Users/xm/Library/Android/sdk
    • Platform android-30, build-tools 30.0.3
    • Java binary at: /Applications/Android
      Studio.app/Contents/jre/jdk/Contents/Home/bin/java
    • Java version OpenJDK Runtime Environment (build 11.0.8+10-b944.6916264)
    • All Android licenses accepted.

[✓] Xcode - develop for iOS and macOS
    • Xcode at /Applications/Xcode.app/Contents/Developer
    • Xcode 12.4, Build version 12D4e
    • CocoaPods version 1.11.0

[✓] Chrome - develop for the web
    • Chrome at /Applications/Google Chrome.app/Contents/MacOS/Google Chrome

[✓] Android Studio (version 4.2)
    • Android Studio at /Applications/Android Studio.app/Contents
    • Flutter plugin can be installed from:
      🔨 https://plugins.jetbrains.com/plugin/9212-flutter
    • Dart plugin can be installed from:
      🔨 https://plugins.jetbrains.com/plugin/6351-dart
    • Java version OpenJDK Runtime Environment (build 11.0.8+10-b944.6916264)

[✓] IntelliJ IDEA Community Edition (version 2021.1.2)
    • IntelliJ at /Applications/IntelliJ IDEA CE.app
    • Flutter plugin version 57.0.5
    • Dart plugin version 211.7233

[✓] VS Code (version 1.60.1)
    • VS Code at /Applications/Visual Studio Code.app/Contents
    • Flutter extension version 3.26.0

[✓] Connected device (2 available)
    • iPhone SE (2nd generation) (mobile) • 2B142514-79F4-48F9-BD92-8544F4935F36 • ios
      • com.apple.CoreSimulator.SimRuntime.iOS-14-4 (simulator)
    • Chrome (web)                        • chrome                               •
      web-javascript • Google Chrome 93.0.4577.82

• No issues found!

Sorry forgot to mention this…
This error mostly occurs when I am using Android device or Android Emulator and very rarely happens for iOS device/simulator…
Thanks…

@absarf Sorry, not sure if this is related to the code attached to the book. Nevertheless, we made a new release today. Might want to check it out. Flutter Apprentice | raywenderlich.com

Finally my prayers answered…
Many many thanks to the RW team…
Cheers…

1 Like