Group Group Group Group Group Group Group Group Group

Errata for Apple Augmented Reality by Tutorials 1st Edition

Page 22

To the bottom of the page there is the line “Finally open .htaccess with a text editor.”

As far as I can see this is the first time this file is mentioned and to a newbie like myself. I do not know where to locate it to make the required changes. A bit more clarity would be useful.

Hope this all helps.

Page 46 Motion Types.
Reality Composer version 1.4 shows the two options to be fixed/dynamic not static/dynamic as shown in the book

1 Like

Thanks for finding and reporting that. Fixed.

You are correct, this is the first time the .htaccess file is mentioned. We’ll see about getting some additional information added to the book. For now, know that the .htaccess file is a configuration file for your website (local or otherwise). It’s also a hidden file, which you can tell by the filename; hidden files start with a period in their name.

Hope that helps, and thanks for reporting this to us.

Thanks! We’ll make a note of it and get it updated.

Page 68 says to set the Position of the kick drum to

(X: 0cm, Y: 0,24cm, Z: 0cm)

The image shows the same Y value of “0,24 cm”. Is that supposed to be 0, 24, or 0.24?

Hello.
I have a question. How can I select multiple objects in Reality Composer when they are one on top of the other.
(Chapter 7, Adding button interactions)

Hi there, it should be 0.24cm. Thanks for reporting the issue.

Hi there, this is a bit of an issue at the moment when working in Reality Composer, mainly because there’s no Scene Object Hierarchy available. To best work around I can suggest is to select the first image, then write down it’s Transform details. Now move it out of the way to expose the next image. Select the next image, write down Transform details for that one, before moving it out of the way. This allows you to get to the other images hidden below. Once you’ve made all your changes, just restore the Transform settings for the images you had to move out of the way.

Hope that helps.

Ok, I will try.
Thank you.

Version 0.3.0, page 261 has a typo. It says

Add the following to sessiongWasInterrupted(_:):

There is an extra ‘g’ in the method name.

1. AR Quick Start

tankAnchor!.turret?.setParent(tankAnchor!.tank, preservingWorldTransform: true)
should be
tankAnchor?.cannon?.setParent(tankAnchor?.tank, preservingWorldTransform: true)

otherwise “Value of type ‘TinyToyTank._TinyToyTank’ has no member ‘turret’” error thrown

1 Like

chapter 16: updating the focus node
“… the app will switch to PointToSurface…”
It should say PointAtSurface which is defined in the appState enum.

chapter 16: Creating the scene
“With the Base node selected…”
It is misleading because when you select the Base node under Base reference, the transform position is uneditable. It should say “Base reference selected”?

chapter 16: creating the scene
The base reference’s position should be (x:0, y:0.049, z:0) instead of (x:0, y:0.49, z:0)

Error in 2. AR Quick Look - Error typos

I’m probably running into an embarrassing newbie problem but on page 20 the line
var tankAnchor: TinyToyTank._TinyToyTank? creates a build error for me. I tried to run the final code as well but same error. I’m on Xcode 11.7 and Catalina (10.15.7). Any ideas? Many thanks…

1 Like

Hi @zig-zag , could you possibly share the exact error you receive when running the code and what solutions you were able to try?

Best,
Gina

Final Update: I ran the app on my iPhone XR and can see the cube and number 15 pool ball in full 3D, along with the table top they are sitting on as viewed through my iPhone’s camera. The error messages appear to be related to audio, which is not being used at this time.

I’m running OS 11.2.2 on a 2017 MacBook Pro and using XCode 12.4 (12D4e). I set up the TinyToyTank Project (several times and got the same results each time) following the instructions. Build Succeeded, but I get only a tiny gray square each time (is this the block I’m supposed to see?) I thought I’d see a 3D image of a block. Below is the debug information I get from Xcode. I have no idea what to make of it. I did verify using Reality Composer that the 3D cube with smoothed edges is in the Experience.rcproject file. But for some reason it was not loaded. OK, an update. Apparently the block was loaded and I’m seeing it from a top-down view, so it appears as a small gray square. How do I know this? I added a 15 pool ball to the cube image in the Experience.rcproject file and built the app again. This time I see the small gray square and the 15 pool ball, so it’s there. Now to figure out how to move the image around in the emulator. Next will plug in my iPhone.

2021-03-30 07:46:34.413838-0500 TinyToyTank[27132:9036281] Metal GPU Frame Capture Enabled
2021-03-30 07:46:34.414287-0500 TinyToyTank[27132:9036281] Metal API Validation Enabled
2021-03-30 07:46:35.191245-0500 TinyToyTank[27132:9036281] [plugin] AddInstanceForFactory: No factory registered for id <CFUUID 0x600000e29ca0> F8BB1C28-BAE8-11D6-9C31-00039315CD46
2021-03-30 07:46:35.221543-0500 TinyToyTank[27132:9036281] Error loading /Library/Audio/Plug-Ins/HAL/JackRouter.plugin/Contents/MacOS/JackRouter: dlopen(/Library/Audio/Plug-Ins/HAL/JackRouter.plugin/Contents/MacOS/JackRouter, 262): no suitable image found. Did find:
/Library/Audio/Plug-Ins/HAL/JackRouter.plugin/Contents/MacOS/JackRouter: mach-o, but not built for platform iOS-sim
2021-03-30 07:46:35.221689-0500 TinyToyTank[27132:9036281] [plugin] Cannot find function pointer New_JackRouterPlugIn for factory <CFUUID 0x600000e29d60> 7CB18864-927D-48B5-904C-CCFBCFBC7ADD in CFBundle/CFPlugIn 0x7fa473508f60 </Library/Audio/Plug-Ins/HAL/JackRouter.plugin> (bundle, not loaded)
2021-03-30 07:46:35.227170-0500 TinyToyTank[27132:9036281] [] [07:46:35.226] FigSTSCreate signalled err=-15994 (kFigSTSError_UnknownFlavor) (Unknown STS flavor) at /Library/Caches/com.apple.xbs/Sources/EmbeddedCoreMedia_Sim/EmbeddedCoreMedia-2765.6/Prototypes/FigSTS/FigSTS_Common.c:157
2021-03-30 07:46:35.227337-0500 TinyToyTank[27132:9036281] [Audio] Failed to create FigSTS object error=-15994
no main.reality file found in application bundle