Environment | raywenderlich.com


This is a companion discussion topic for the original entry at https://www.raywenderlich.com/15234721-your-second-ios-and-swiftui-app/lessons/22

By the end of this video, my app’s NewBookView’s “Add to Library” button only gets enabled when I populate the title, author, and review! Filling in the title and author only do nothing. In fact, if I populate the review first, then the title and author, it still doesn’t work. After editing the review a second time then it works.

How do I get rid of this bug? My code follows yours exactly as far as I can tell. Getting a weird error message pop up saying, “Make a symbolic break point at UIViewAlertForUnsatisfiableConstraints” - in the output after running.

Sorry you’re having trouble—upload your project and I’ll have a look!

Not really seeing a place to upload a whole project. Can you tell me where on the website/page I might upload it?

There should be a button for uploading files in the reply dialog. I’ve heard that it isn’t available for new posters though, and I don’t know at what point the restriction is let up. If you don’t have that option, people typically send Github or Dropbox links.

Yes you are right, no option as a new poster. Here is my GitHub link: https://github.com/Tommy-Sun/ReadMeIOSProject.git

That is only the Xcode project file. I’ll need the encompassing folder, so I can see the rest of your files.

Okay, sorry for the inexperience. It should be good to go now.

Did you forget to push? It’s the same version from 2 days ago.

Try now. Not sure why it didn’t work the first time.

You didn’t make Book's title and author Published, so the view isn’t informed that it needs to update. Fortunately, that fix was only one video ago: Challenge: New Book Sheet | raywenderlich.com

I appreciate the quick replies! That tip worked!

1 Like