Couldn't parse contents of info.plist - xcode

I am close to launching a game of mine, but just faced a great obstacle!

My code works just fine, however, as I build my project, it gets an error about the info.plist:

couldn't parse contents of '/Users/ ... /Info.plist': The data couldn’t be read because it isn’t in the correct format.

The identity in AppName´s General says only:
"Xcode failed to parse the contents of the Info.plist"

The info section in Xcode says:
Information from info.plist not available. File may not exist at specified path.

I have no idea what to do. Please help!
In advance, thank you!

Chances are you have edited the plist format and it is no longer correct XML. What you could do is use an XML verification tool like http://www.xmlvalidation.com - perhaps you a stray character and a tool like this will pinpoint it easily.

Another strategy would be to go back in your revision control system to when it worked and to compare your last good commit with what you have now. Even simpler, use the git history view in Xcode to find out when it changed. You ARE using git, right?

The rightmost of the three buttons (arrows pointing left and right) activates the git view.

Hi!
Thank you so much for giving this a shot!

I do not fancy using the online verification tool.

As for the other ideas, I am quite interested. Unfortunately, I am not very familiar with these tools. I have tried searching help online, but I do not really get it. Do you have any links or further information to give me a hand?

Once again, I am really gratefull for you helping me!
Thank you!

I did it!

After hours, I simple copied the info.plist (the whole file) from the test-version and substituted it with the one in the main project that would neither work or open.

Then it simply worked!

Good to know! One reason I dislike working in XML is that it can be even harder than JSON to verify correctness by looking at it. Don’t discount the online lint tools, I use JSON lint all the time and it saves hours hunting for stray commas.