Group Group Group Group Group Group Group Group Group

Coffee Quest (iOS 13) Chapters 10-13 won't Run

Hi, enjoying the book. Great resource.

It seems that each final version of the Coffee Quest App (chapters 10 - 13) fails to load. All have the same error. Did other people find the same thing?

As a workaround, I downloaded the iOS12 version & worked with those files which still run fine.

Thanks

CoffeeQuest

I had this problem also using Xcode 11.4.1. The build log indicates that it is a ‘Permission denied’ problem while running Pods-CoffeeQuest.frameworks.sh.

However, using the iOS 12 files as per @and1’s suggestion works.

As an aside, not sure why it is necessary to use Cocoapods in order to demonstrate the use of MVVM. It seems like an unnecess complication.

@and1 @lesormonde Do you still have issues with this?

I used an earlier version of the files and everything worked ok so it isn’t causing me a problem but AFAIK the issue still exists.

@jstrawn Can you please help with this when you get a chance? Thank you - much appreciated! :]

I am having the same issue here. Any updates on how to tackle?

For what is worth, the same thing happened to me.

Seems to be related to permissions around Cocoapods and something changing with the latest version of either pods or Xcode, either way, this fixed it for me:

$: pod deintegrate && pod install

This will remove and install the pods and set the proper permissions, I was up and running after this.