Cocoapoads does not work properly. How to fix it?

Hello everyone! I was trying to add multiple libraries / frameworks into my Xcode project by using cocoapods. However, it did not worked. It showed me this error. And this happened with all libraries / frameworks that I tried to add. How to fix it? And Is there a way to add library / frameworks without cocoaPods?

Hi @dafk! Could you tell us the steps you took that led to this error please? The error message doesn’t give me much to go off of.

Best,
Gina

@dafk Is this occurring on a new Apple Silicon M1 machine? If so, this appears to be a scenario experienced by others. I have found the following solutions which may help:

sudo arch -x86_64 gem install ffi

Then

arch -x86_64 pod install

another option is:

1- Go to your applications > utilities folder.
2- Right click and click “Get Info” on your terminal app
3- Check “Open Using Rosetta” option
4- Start your terminal app
5- sudo gem install cocoapods
6- sudo gem install ffi
7- pod install

I hope these help!

All the best.

I have created podfile. And tried to add several libraries. I got error when in terminal i entered pod install.

@dafk, did @syedfa’s recommendation work?

Best,
Gina

This topic was automatically closed after 166 days. New replies are no longer allowed.