Group Group Group Group Group Group Group Group Group

Chapter 3: Kick.usdz import super small

Just installed Blender so first time using it, but I’m pretty sure I followed the instructions exactly. When I import the Kick.usdz file into my scene in RealityComposer, it is super small…have to scale up to 10,000% to look normal. Perhaps something simple I’m missing? It imports as expected if I use the file provided by the course.

Couple other notes:

  • Rotation, scale and dimensions in Blender appear to match book
  • When the Blender-exported Kick.usdz is imported into RealityComposer, the thumbnail looks like a ghostly outline instead an actual kick drum
  • The course-provided file imports fine and looks fine when added to the scene

@chrislanguage Can you please help with this when you get a chance? Thank you - much appreciated! :]

Hi there, I’m unable to reproduce the issue you’re experiencing. When you open the Blender project and select the Kick drum for export, the most important thing to do is to APPLY ROTATION & SCALE. This is part of the instructions in the book. My tests showed that after applying Rotation & Scale, the physical size of the Kick drum is (X: 0.836m, Y: 0.71m, Z: 0.822m) at a scale of 1.0. That’s exactly the correct measurements of a Kick drum in the physical world.

My suggestion is to check if you get the same measurements after you’ve applied scale & rotation. If not, then your Blender might using different unit settings?

Here’s what mine is set to:

Hope that helps.

I meet the same issue when following the instructions in this book. My blender version is 2.90.1 and usdpython is 0.64.

I also tried to convert the .glb file in the start folder to .usdz, but unfortunately, it was still a very small one

I’m seeing the same thing (Kick drum really small) with Blender 2.90.1 and usdpython 0.64.

Confirmed I have the same unit settings as Chris.

Update: I made some progress here. I converted the USDZ to USDA and inspected the text.
I found this line at the top which was suspicious:

metersPerUnit = 0.01

This value (0.01) is the same regardless of if I set the units to Meters or Millimeters in Blender.

If I change metersPerUnit to 1.00, convert to USDC and then use Reality Converter to convert back into USDZ it works. (There is a bug with usdzconvert v0.64 converting USDA/C to USDZ where they are using a hardcoded path from one of the authors in the CPP and it throws an error.)

@chrislanguage do you have any idea what might be happening here? thanks!

3 Likes