Group Group Group Group Group Group Group Group Group

Chapter 24: MVVM with RxSwift - problems

starter (and final) folders compiles but crashes with the error:

Terminating app due to uncaught exception 'RLMException', reason: 'Primary key property 'name' does not exist on object 'RealmSwiftPermissionRole'

Now, after I updated Podfile by removing any version specifications, cleaning DeriveData, and compilation error for Tweet.swift, I was able to run the app.
Alas, most of the icons could not be loaded because of 404 error: Fetch image error: n/a

P.S. is it because I run Xcode 11.3.1?

1 Like

@konic Do you still have issues with this?

The same problem, neither starter nor final project not compiled for me whit the same error.

in podfile
pod ‘RealmSwift’, ‘~> 3.20.0’

in terminal
pod repo update
pod install

Resolved my problem.

Thanks @silentgnom - in the next iteration of the book we will make sure do update those dependencies

1 Like

Very thanks, I like your book, you explained so hard topic so easy. You are definitely teacher from god. (Sorry for my English, if it translated something wrong :blush:))

@silentgnom Really glad you like it! Cheers! :]

This topic was automatically closed after 166 days. New replies are no longer allowed.