Group Group Group Group Group Group Group Group Group

Chapter 2: Observables project problems

Hi,

I had problems with the project, first I could not build without doing “pod install”, and it only works with Xcode 8.1 , I have tried with the last version of XCode (8.3) and it does not work, I can’t build the project. What do I need to work with Xcode 8.3 .

Thanks in advance,

Felix.

Hi Felix, in the first chapter of the book “Hello, RxSwift” there is detailed information about which version of Xcode you need and how to run each chapter’s project. Enjoy!

The Xcode version is mentioned right under the book name on the book page as well: https://store.raywenderlich.com/products/rxswift

Hi icanzlib,

Thanks for you answer.

With Xcode 8.1 I can work without any problem, my question was if there is any way to work with the last stable version of Xcode 8. Is the problem than RxSwift is not compatible with Swift 3.1?

I’m enjoying the book a lot.

Greetings.

I’m not sure about this, as far as I know 8.3 came out some time last week and I still hadn’t have the chance to try it out. Maybe somebody else has tips for you :slight_smile: Or try the RxSwift Slack channel, for sure there are users there who had time to migrate to Xcode 8.3 :ok_hand:

I’ve tried building several of the projects and they all break — missing Info.plist errors.

Failed to read Info.plist of app /Users/xxx/Library/Developer/Xcode/DerivedData/RxSwift-exlhtfwnjdsubadmwfwnzhiabjgp/Build/Products/Debug-iphoneos/RxSwiftPlayground.app

This is under Xcode 8.3 (I know you list 8.1, but really…) I can find an “info.plist” in Derived Data, in lowercase.

1 Like

Links to the Forums page in the book on Page 18 is wrong — returns 404.

Hello we haven’t heard about such a problem from any of the other readers. Have you followed the instructions how to run the projects found in the first chapter? Additionally - the projects most likely will not work on Xcode 8.3

Oh that’s true - the link to the forum uses the old url, which changed. Thanks a lot for that, we’ll fix in the next edition.

Oh, huh. Okay. I’ll download 8.1 and give it a try.

Why not? I can confirm it doesn’t work on version 8.3, but would appreciate a better explanation if I’m going to have to download a 5 gb IDE just to work through these tutorials.

1 Like

because we haven’t tested all code + text with Xcode 8.3 and if I know something it’s that most often than not Xcode isn’t running previous version code out of the box. if people report bugs in the book using Xcode 8.3 we can’t address those for that reason, that’s why the versions are specified on the book page and on the book cover :slight_smile: We’ll update to the next latest version in the 2nd edition of the book (as we do with all rw.com books)

Ok, thank you for the response! :slight_smile:

Same error here…the simplest thing to do is to create an info.plist file and in build settings when asked for info plist file specify the folder path i.e. ./info.plist

After this an other problem with Xcode 8.2.1 and Xcode 8.3 is that the import RxSwift reports no such module RxSwift

1 Like

tell me for which project is that happening? with both Xcode 8.2.1 and Xcode 8.3? Did you run pod install in that directory?

Sure i did pod install in the same directory, this error is on Xcode 8.2.1 and Xcode 8.3 for example in the first starter project (chap 02)

Could you post a screenshot with the Xcode window visible so I can see how the project navigator looks like and where the error pops up? We’ll find out what’s happening, no worries

I’ve found a little workaround.
https://www.dropbox.com/s/r7ooi8pdnkrhx9a/RxPlayground.zip?dl=1
But is needed change Workspace configuration:


2 Likes

After adding Info.plist manually it’s necessary to switch to the simulator and not to the device. Try to build and it works!

1 Like

creating an Info.plist file and changing the workspace settings worked for me. Xcode 8.3.1