Group Group Group Group Group Group Group Group Group

Chapter 2 - Library not loaded / Image not found

I purchased the book Server-Side Swift with Vapor. When I follow the instructions to install Vapor I get the following results:

Diamond:vapor admin$ eval “$(curl -sL check.vapor.sh)”

Diamond:vapor admin$ brew tap vapor/tap
Updating Homebrew…
==> Auto-updated Homebrew!
Updated 1 tap (homebrew/core).
No changes to formulae.

Diamond:vapor admin$ brew install vapor/tap/vapor
Warning: vapor/tap/vapor 3.1.10 is already installed and up-to-date
To reinstall 3.1.10, run brew reinstall vapor

Diamond:vapor admin$ vapor --version
dyld: Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib
Referenced from: /usr/local/bin/vapor
Reason: image not found
Abort trap: 6
Diamond:vapor admin$

How do I resolve this issue?

I had exactly same issue. And I checked openssl folder, I have libssl.1.1.dylib not 1.0.0.
So I tried to make symbolic link file in /usr/local/opt/openssl/lib using (ln -s ./libssl.1.1.dylib ./libssl.1.0.0.dylib) and (ln -s ./libcrypto.1.1.dylib ./libcrypto.1.0.0.dylib). It looks like working well. but not sure if it’s right solution or not. Or do I need to downgrade openssl? Anyway I don’t understand why vapor search specific version of openssl not libssl.dylib. Does anyone know how I can fix this?

Your link solution worked for me, thank you. I too would like to know how I can fix this without creating a link.

Brew removed OpenSSL 1.0 in the last couple of days which the Vapor toolbox relies in. If that solution works that’s great! But we’re currently discussing a more permanent solution