Group Group Group Group Group Group Group Group Group

Chapter 12 - Putting it all together: Errors linking frameworks

#1

Hello,

I’m not very experienced with CocoaPods. How do I properly link the frameworks? Getting errors such as:

NotificationViewController.swift: No such module ‘CalendarKit’

AppDelegate.swift: Use of unresolved identifier ‘Invite’

Thank you!

#2

@gargoyle Can you please help with this when you get a chance? Thank you - much appreciated! :]

#3

Hi there. Open up a Terminal and go to the top of the project, where the Podfile is. From there you can run the command “pod install” and it’ll install all of the dependencies for you.

#4

The POD issues might be a red herring as Xcode is complaining about your Invite class as well. From your picture it seems like you probably are already using the workspace, as opposed to the project, and the sample files came with an installed version of the PODs.

Suggest you look at your errors list and work top-down. Resolving your Invite core data item, for example, might fix the pod. Granted, it could be the other way around too :slight_smile: