Group Group Group Group Group Group Group Group Group

Chapter 12: How to Add a UIView with a transparent background to ARKit Scene

#1

Hi all, I’ve been trying to create a UIView which has a transparent background.
If the view’s background is transparent view, If I add it to the plane Node’s geometry.diffuse.contents, the transparent parts render white on the plane.

There are some solutions on this where instead of setting the UIView as diffuse.contents of the plane geometry, we can set UIView.layer to the diffuse.contents.

The issue with this is that the view is not interactive anymore.

Any ideas?

#2

@jeden Can you please help with this when you get a chance? Thank you - much appreciated! :]

#3

Hi, have you tried embedding your view into another view, and setting its layer to diffuse.contents? Not sure if it works, but it’s worth giving a try.