Chapter 11 Permission issues

It’s already quite annoying that for every chapter I have to open the project file, get a warning that the project was downloaded from the internet, click open, close the project, run pod install, open the workspace. If it is a playground project… i have to also open the playground project and allow the OS to open it.

Now for chapter 11… I have tried opening every playground and project files, I still get this annoying error :

“The file “RxSwiftPlayground” couldn’t be opened because you don’t have permission to view it.”

Using macOS Sierra 10.12 and Xcode 8.3.3

I’m not sure how can we solve the fact that you get the source code from the internet and macOS has a warning about that … or that you need the dependencies for each project that need to be installed … if it causes you so much pain, please reach out for a refund and return the book.

xattr -rd RxSwift*

Will remove the quarantine flags on all the examples but chapter 11 will still give some permission errors.

This topic was automatically closed after 166 days. New replies are no longer allowed.