Group Group Group Group Group Group Group Group Group

Ch 9 -- Campus app

#1

When I try to run the app on the simulator – both starter and complete – in Xcode 9.1 the build appears to complete successfully but then I get a dialog saying “the app was unable to be installed” Following advice from we, I tried deleting derived data, restarting Xcode and doing “Product > Clean”. I have done each several times in multiple combinations with no success.

I have tried multiple simulator targets (iPhone 8, iPhone 7, etc) and multiple iOS; all with the same result.

In addition, I have tried to install onto a physical device. After setting the deployment target to accept my device (iOS 11.0) I got the following error:

error: WatchKit App doesn’t contain any WatchKit Extensions whose WKAppBundleIdentifier matches “com.razeware.Campus.watchkitapp”. Verify that the value of WKAppBundleIdentifier in your WatchKit Extension’s Info.plist matches the value of CFBundleIdentifier in your WatchKit App’s Info.plist.

I downloaded the app collection of October 25.

Suggestions (please).

#2

@benmorrow Do you have any feedback on this? Thank you - much appreciated! :]

#3

Thank you for the heads up, @shogunkaramazov.

@ggtowell I investigated and turns out you were correct. I fixed the code and you should be able to run the app in these updated projects (1.7 MB). I’m also working to get the updated projects made available in the RW Store download. :grinning:

closed #4

This topic was automatically closed after 166 days. New replies are no longer allowed.