Group Group Group Group Group Group Group Group Group

Catnap - tail not moving

#1

I have started working on on Catnap after completing ZombieConga. I’ve completed the Cat.sks file in scene editor. Within the editor the can moves its tail. I then added a reference object in Gamescene.sks to the Cat.sks file. But when I run the game in the simulator the cat tail does not move.

I grabbed the code from the challenge and built and ran that and the cat tail does move. So I’ve tried the best I can to compare the files to see what might be causing the problem. In fact, eventually I took the Cat.sks file from the challenge and dropped it into my version of Catnap to see if that would fix the problem. It didn’t.

Any idea what might be causing this problem? I’ve seen people refer to the impause property. I’ve gone ahead and set that to false, but that didn’t seem to fix anything.

Any help would be appreciated. This is the first major problem I’ve run into so far and want to fix it before moving on.

#2

FWIW, I found the fix to this issue in another thread below that deals with Chapter 7. Apparently the issue is that in Xcode9 the node IsPaused property is, by default, set to true. A quick way to fix this – and you’ll find the code snippet in one of the replies to the thread – is to enumerate through all the child nodes and set all node.IsPaused = false.

Anyway, hope that helps people who run into this.

#3

@swiftlearner1 Thank you for sharing the solution - much appreciated!

closed #4

This topic was automatically closed after 166 days. New replies are no longer allowed.