Group Group Group Group Group Group Group Group Group

Beginning RxSwift - Part 3: Installing RxSwift | Ray Wenderlich Videos

See how to install RxSwift in an Xcode project using CocoaPods, and how to add a playground to a project.


This is a companion discussion topic for the original entry at https://www.raywenderlich.com/4743-beginning-rxswift/lessons/3

Firstly, thanks @scotteg for making this course. I have wanted to mess with RxSwift.

A note for all, I just could not get the import in a playground to work even with all the extra steps, until I changed my active scheme from my iPhone to a simulator. It seems that for some reason everything works fine when you don’t choose an actual device.

Hope this helps.
Peter.

1 Like

Thanks for pointing that out Peter!

Hi Scott,

@scotteg

I could not get this to work in a playground using CocoaPods. I’m having the same issue as reported in Playground does not execute on first chapter

I am using CocoaPods version 1.5.0 and Xcode 9.3. I did not try to use an older version of CocoaPods - it didn’t work for some people in the above thread, and doesn’t feel like the right way to fix it.

I did however get this to work using git submodules. See my reply at Playground does not execute on first chapter

Thanks Scott, I got it working by downloading the material for this episode and using the final project.

Hi Scott
I have problem with the being I try to put the import RxSwift it showed me fail with compiler errorNo such module ‘RxSwift’…

How to solve this …?

Hey Scott,

Xcode 9.3.1, tried all the tricks, I get this error and the Framework is in red, so it’s not building. Any ideas? Yes, I know, Xcode can be a pain!

error: Couldn’t lookup symbols:
__T07RxSwift14ObservableTypePAAE4justAA0C0Cy1EQzGAHFZ
__T07RxSwift14ObservableTypePAAE2ofAA0C0Cy1EQzGAHd_AA018ImmediateSchedulerD0_p9schedulertFZ
__T07RxSwift10ObservableCyxGAA0C4TypeAAWa
__T07RxSwift10ObservableCMa
_T07RxSwift14ObservableTypePAAE2ofAA0C0Cy1EQzGAHd_AA018ImmediateSchedulerD0_p9schedulertFZfA0

1 Like

@scotteg Can you please help with this when you get a chance? Thank you - much appreciated! :]

OMG, I have solved this problem.
First I have to downgrade my cocoapods to v1.3.1, then I followed the nuke and repave.
It still showed the error No such module ‘RxSwift’ but when I change the scheme into an iOS simulator and it works.
Thanks for all your help.

In Xcode 12 you’ll need to select Build Active Scheme in the playground settings for it to work