App Icon and Display Name | raywenderlich.com


This is a companion discussion topic for the original entry at https://www.raywenderlich.com/18176818-your-first-ios-and-swiftui-app-polishing-the-app/lessons/40

Didn’t work
Insert all icon in Assets.xcassets AppIcon but not changed.
And change Display Name in target Bullseye, show error when build

<unknown>:0: error: cannot load module 'Bullseye' as 'Bull_s_Eye'
Command MergeSwiftModule failed with a nonzero exit code

I change Bullseye → Bull’s Eye

Is it related to this?

(In Signing & Capabillities)
Failed to create provisioning profile.
“There are no devices registered in your account on the developer website. Select a device run destination to have Xcode register it.”

No profiles for ‘com.eungi.Bullseye’ were found
“Xcode couldn’t find any iOS App Development provisioning profiles matching ‘com.eungi.Bullseye’.”

It’s working now. But I don’t know what I changed.

Hello, I just came along to this same error. @eungi did you ever pin down exactly what the solution was?

I’m wondering if it’s also because I named my project something else in the very beginning of this tutorial?

Thanks for the help!

Now that I think about it, it have been solved after turning xcode off and on.
The signing problem doesn’t matter.
ㅇㅅㅇb

If anyone is still having this issue, following the steps from xcode - Build fails with "Command failed with a nonzero exit code" - Stack Overflow fixed it for me. This involved going to ~/Library/Developer/Xcode/DerivedData by pasting ‘cd ~/Library/Developer/Xcode/DerivedData && open .’ into my terminal and deleting all of the files in there. I have no idea why this fixed it, but it did.

1 Like

After changing the Display Name, I also experienced the build failing. I tried closing and reopening Xcode, but that didn’t seem to make any difference. The solution that worked for me came from How to change app display name in Xcode 8 to add a space . Involves adding Bundle display name to the Custom iOS Target Properties in the Project Info tab. Even though this solution is from an Xcode 8 issue, it worked for me.

The simplest solution I found was after changing the display name in the “General” tab I went to the “Info” tab & added a new key by clicking the plus sign next to “Bundle name”. There will be a dropdown menu; scroll to the one that says “Bundle display name” & click on it. Its value will be empty so type in “Bull’s Eye”. Once you do that go to the top of your screen where there are “Xcode File Edit View Navigate … ect.” Click on “Product” & scroll down to “Clean Build Folder” & click it. The simulator should now build your project with no issues.

“Clean Build Folder” works for me. Thanks!