Group Group Group Group Group Group Group Group Group

Animations paused by default?

#1

Hi, in my project all the animations created in the sks files are paused by default at the beginning.
If I programmatically set the property of this objects isPaused as true, works. But it’s annoying and in the examples files I saw that works fine.

Will I be skipping some configuration in the project or something?

#2

@chemajuarez Could you please let me know which examples work correctly in your case when you get a chance? Thank you!

#3

In catnap exercise the example files works fine, mine’s not. But I saw a possible solution setting isPause property to false.

Thanks.

#4

Hi, I face the same problem.

Instance of let’s say CatNode is paused by default, so cat animation is not working if I don’t set isPaused to false explicit.

I guess, the reason why are provided samples are working could be difference in build settings or something like that.

I’m pretty sure I followed instructions in book and compared code and scenes’ settings, they are looks the same.

Also when I completed CatNap on swift 3.* version, I didn’t have this problem.

Not sure how to enable isPaused to true by the default for all custom class nodes.

closed #5

This topic was automatically closed after 166 days. New replies are no longer allowed.