Group Group Group Group Group Group Group Group Group

Android Apprentice Chap 1 Setup


#1

Hello,

I am setting up for Timefighter in the Android Apprentice project.
After the setup is completed and the code is loaded, I get an error on this import statement.

import android.support.v7.app.AppCompatActivity

Within the statement above the word, app, is indicated in error. It is in red text.

Appreciate any assistance.

Wes


#2

@daemonic_daz Can you please help with this when you get a chance? Thank you - much appreciated! :]


#3

Hey whodges007,

Sorry to hear you’re having issues. Could you give a little more information on how the setup is completed? Hopefully we can get to the bottom of this.

Darryl


#4

Hello and thank you very much for getting back to me.

I am happy to say that the problem is resolved. I deleted the work I had done which had somehow introduced the errors and opened the files provided with the book purchase. Once I saw that everything was working as described, I deleted that project and began from the beginning once again. This time I had no errors. The eBook states the following:

Locate the projects folder for this chapter and open the TimeFighter app under starter. The first time you open the project, Android Studio takes a few minutes to set up your environment and update dependencies. (Android Apprentice, D. Bayliss & T. Blankenship, Page 48).

Perhaps whatever error I was experiencing was corrected when I followed those instructions.

Thanks,
Wes


#5

Hey Wes,

That’s great to hear everything is working for you.

I hope you’re finding the book useful. If there’s any other issues you run into, let us know and we’ll be happy to help.

Darryl